Problems with Telephone System
Incident Report for Speak Digital
Resolved
We believe that the problems over the last 24h are fully resolved now. We will be checking things overnight to make sure all is 100% for tomorrow. We will also conduct a post-mortem review to decide if changes need to be made as a result of this event. Thank you for your patience and once again please accept our apologies. Thank you.
Posted Mar 18, 2021 - 17:56 UTC
Update
Our supplier believes one way audio on calls were addressed by 11:25. Outbound calls also appear to be working normally. They continue to process call logs to identify any remaining issues but please do report ongoing issues to us via helpdesk@speakdigital.co.uk. An update will follow by 12:30
Posted Mar 18, 2021 - 11:51 UTC
Update
Our supplier has made further changes to improve the situation. Please do send examples through if your calls are falling. Most calls seem to be working ok from our office so we hope the same is true for you.
Posted Mar 18, 2021 - 11:15 UTC
Update
Sorry, further to the last update we are still seeing problems. It would be helpful if you could send in examples to helpdesk@speakdigital.co.uk detailing Numbers involved, Extension involved. Timestamp involved, Direction (Inbound/Outbound) and a description of what occurs during the call. We are still applying as much pressure as we can and monitoring this very carefully.
Posted Mar 18, 2021 - 10:38 UTC
Monitoring
Call issues should now be resolved. If you are still not able to make/receive calls please try rebooting your handsets. Please let us know if you are still having problems so we can report this to the supplier. Please try to give us full details of the caller, callee, time of call and what didn't work. Thanks for your patience.
Posted Mar 18, 2021 - 10:29 UTC
Identified
Our supplier has done some mitigation work however we are still seeing problems for both incoming and outgoing calls. Most calls are succeeding but some are still failing. We have reported this back and are applying as much pressure as we can to get this resolved. They have promised the next update by 10.20.
Posted Mar 18, 2021 - 09:58 UTC
Investigating
Further to yesterday we are experiencing problems again this morning. We are putting pressure on the supplier as we realise this is not acceptable. Please bear with us and if you need to contact us email helpdesk@speakdigital.co.uk
Posted Mar 18, 2021 - 09:32 UTC
Monitoring
The services from the Leeds node have now been failed-over to the London node and all services should be operating normally. Please do let us know if you are still experiencing issues. Apologies for any disruption.
Posted Mar 17, 2021 - 16:46 UTC
Identified
Our supplier have identified a network issue affecting their Leeds node and have moved calls elsewhere to ensure calls now complete. Please restart your phones if you are still having problems. You may still notice a delay when making outbound calls.
Posted Mar 17, 2021 - 14:20 UTC
Investigating
Our supplier are currently investigating reports of issues with calls dropping. This is also stopping us from receiving some support calls so if you cannot get through please email helpdesk@speakdigital.co.uk and we will call you back. Thank you.
Posted Mar 17, 2021 - 13:41 UTC
This incident affected: VOIP Phone System.