TeamViewer Remote Control Not Functioning
Incident Report for Speak Digital
Resolved
This incident has been resolved.
Posted Mar 22, 2021 - 14:34 UTC
Monitoring
TeamViewer report that a fix has been implemented and they are monitoring the results. We have been able to reconnect so please let us know if you are having problems, Thank you
Posted Mar 22, 2021 - 09:18 UTC
Update
TeamViewer now report their engineers have not yet confirmed the underlying root cause and they are working on the identification.
Posted Mar 22, 2021 - 09:05 UTC
Investigating
Good morning. We have had problems connecting to TeamViewer. Their status page does not show any issues but Twitter and DownDetector are showing reports of problems. We will keep an eye on things and report back here when we know more.
Posted Mar 22, 2021 - 08:56 UTC
This incident affected: TeamViewer Remote Access and Support.