Users not able to connect to Citrix
Incident Report for Speak Digital
Resolved
Sorry for not updating this platform but this issue was resolved before 9am.
Posted Mar 19, 2021 - 09:10 UTC
Identified
Engineers working on the issue believe it has been caused by some failed updates. They are working hard to restore normal service as soon as possible.
Posted Mar 19, 2021 - 08:30 UTC
Investigating
Users have reported not being able to connect to Citrix and seeing error "Http/1.1 Internal Server Error 43531". We are looking into this and hope to update you shortly.
Posted Mar 19, 2021 - 08:13 UTC
This incident affected: Citrix Hosted Desktops.