Further problems with VOIP phones
Incident Report for Speak Digital
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 15:55 UTC
Monitoring
We are informed that all systems are normal. If you are still having problems please report them to us. Thank you
Posted Oct 15, 2020 - 13:54 UTC
Investigating
Following the issues yesterday we are noticing a few problems with making and receiving calls today. We are investigating this but for now please restart your handset and try again in a few minutes.
Posted Oct 15, 2020 - 11:37 UTC
This incident affected: VOIP Phone System.