Various hosted services down
Incident Report for Speak Digital
Resolved
This incident has been resolved.
Posted Oct 13, 2021 - 10:46 UTC
Monitoring
OVH connectivity appears to be back up and all our direct services with them are working normally. There may be some knock on effects for other services that do not come back so quickly.
Posted Oct 13, 2021 - 07:46 UTC
Identified
OVH, a major supplier of servers and internet services, are currently down. This will affect customers who host servers with us but will also have knock on effects for major websites and services provided by other companies who use OVH infrastructure. We will keep you updated via this status page.
Posted Oct 13, 2021 - 07:38 UTC
This incident affected: Broadband / Internet Connectivity and Other Notifications.