Hosted Desktops Losing Connections
Incident Report for Speak Digital
Resolved
This incident has been resolved.
Posted Mar 04, 2021 - 17:51 UTC
Monitoring
Most users have been able to reconnect now following the interruption. We are keeping an eye on things. If you do get disconnected please let us know and keep a note of the time. Thank you.
Posted Mar 04, 2021 - 14:41 UTC
Identified
We have been notified of problems at the datacentre which is causing users to be thrown out of Citrix. This is being worked on now. In the meantime if you are on a hosted desktop please make sure you save your work regularly in case you do get disconnected.
Posted Mar 04, 2021 - 13:54 UTC
This incident affected: Citrix Hosted Desktops.