Calls taking time to establish
Incident Report for Speak Digital
Resolved
We have not had any further reports of problems but are keeping an eye on things. If you do have any issues with the phone system please let us know. Thanks very much
Posted Apr 13, 2021 - 09:49 UTC
Investigating
We are noticing that outgoing calls are taking time to connect after dialling. This is being investigated. Please hold on as the call does connect after 5-10 seconds. We will update you once we have more information.
Posted Apr 13, 2021 - 08:48 UTC
This incident affected: VOIP Phone System.