Office 365 Email Outage
Incident Report for Speak Digital
Resolved
Microsoft report that incident EX216336 is now resolved. Sorry for any disruption caused.
Posted Jun 15, 2020 - 18:38 UTC
Update
Microsoft have not resolved the issue yet and say the next update will be at 6pm. Sorry for any problems this is causing.
Posted Jun 15, 2020 - 15:20 UTC
Identified
Microsoft have acknowledged a fault with Outlook accessing emails this afternoon. Please use https://outlook.office365.com as a workaround until this is resolved. Next update is expected at 4pm.
Posted Jun 15, 2020 - 14:17 UTC
This incident affected: Microsoft Office 365.