Microsoft Office 365 Email Issues
Incident Report for Speak Digital
Resolved
This issue appears to have been resolved now.
Posted Jun 21, 2022 - 16:52 UTC
Identified
Customers should be advised we are noticing delays with email delivery as well as some users not being able to connect to their mailboxes.
This is related to Microsoft incident EX394347 and they are currently working on resolving it.
Posted Jun 21, 2022 - 10:54 UTC
This incident affected: Microsoft Office 365.