VIOP Phone Platform Issues
Incident Report for Speak Digital
Resolved
This issue was caused by a problem at our supplier and it was quickly resolved by their team.
Posted May 20, 2020 - 14:12 UTC
Monitoring
All seems to be working well now. We are checking with the supplier to find the cause.
Posted May 20, 2020 - 09:46 UTC
Investigating
Some customers are unable to make or receive calls. We are checking this with our supplier now.
Posted May 20, 2020 - 09:24 UTC
This incident affected: VOIP Phone System.