VOIP Phone System Down
Incident Report for Speak Digital
Resolved
This incident has been resolved.
Posted May 28, 2024 - 10:18 UTC
Monitoring
The problem seems to have resolved itself and we are back online.
Please let us know if you are still having any issues. Apologies for any disruption.
Posted May 28, 2024 - 09:01 UTC
Investigating
We have just seen our VOIP services go offline. We are investigating this.
If you need to reach us please email helpdesk@speakdigital.co.uk and we will call you back.
Posted May 28, 2024 - 08:59 UTC
This incident affected: VOIP Phone System.