Unable to make Outoing Calls

Incident Report for Speak Digital

Resolved

Our supplier identified an update on the system that caused certain outgoing calls to be blocked. They mitigated the issue within 40 minutes and have given us a detailed breakdown of what happened. Apologies for any inconvenience caused.
Posted Aug 01, 2025 - 12:50 UTC

Monitoring

This issue appears to be resolved but we are wating on confirmation from our supplier.
Posted Aug 01, 2025 - 11:25 UTC

Identified

Our supplier has confirmed they are experiencing an issue and their engineers are working on establishing the cause.
Posted Aug 01, 2025 - 11:10 UTC

Investigating

We have reports that clients are unable to make outgoing calls from our VOIP platform. We are currently looking into this to establish the cause with our supplier.
Posted Aug 01, 2025 - 10:58 UTC
This incident affected: VOIP Phone System.