Zen Service - Outage Alert

Incident Report for Speak Digital

Resolved

This is confirmation that the outage affecting any Zen Broadband Service should now be resolved.
Posted May 14, 2025 - 10:47 UTC

Monitoring

Zen have alerted us that some services are affected by an on-going network outage - this may cause total loss or intermittent connectivity of your Zen Broadband Service. We will keep you updated as we hear more but if you do have an outage please let us know.
Posted May 14, 2025 - 10:07 UTC
This incident affected: Broadband / Internet Connectivity.