Telephone System Issues
Incident Report for Speak Digital
Resolved
Our supplier reports that all services are now working, we apologize for any inconvenience.
Posted Oct 14, 2020 - 16:29 UTC
Identified
Our supplier is continuing to work hard on resolving this issue. Unfortunately some calls are being affected but some are going through ok. Please bear with us and apologies for the downtime.
Posted Oct 14, 2020 - 15:36 UTC
Monitoring
The issue seems to have resolved but we are monitoring to make sure there is no further impact.
Posted Oct 14, 2020 - 14:25 UTC
Investigating
We have multiple reports of problems with the phone system. We are investigating with the supplier and will update you here shortly.
Posted Oct 14, 2020 - 13:46 UTC
This incident affected: VOIP Phone System.