Problems dialling calls
Incident Report for Speak Digital
Resolved
The incident has now been resolved. Apologies for any disruption during today. If you would like a written incident report next week please let us know.
Posted Nov 20, 2020 - 18:29 UTC
Monitoring
Further update from our supplier: The situation is markedly better and we ensuring that customers have confirmed that to us.
The delay on processing call recordings will remain in place and this incident will remain open for now.
Posted Nov 20, 2020 - 13:24 UTC
Update
Further update: Mitigation work has reduced the high loads have and call volumes are returning strongly. Please note that as a precaution, call recordings are not being processed currently but they are still taking place - so will be processed later.

We are continuing to work on this and apologise for the disruption.
Posted Nov 20, 2020 - 12:04 UTC
Update
Update from our supplier at 10.50: We are working on mitigating and resolving the call failure issues. Apologies for the extended time taken in dealing with this.
Posted Nov 20, 2020 - 11:04 UTC
Identified
The supplier has identified the problem and is working on it. Many apologies for the disruption.
Inbound and outbound calls are being affected - this is being treated as top priority.
Posted Nov 20, 2020 - 10:39 UTC
Investigating
We have had reports of customers getting an error when making outbound calls.
If this happens to you please email helpdesk@speakdigital.co.uk and give at least 3 examples with the following information:
Extension making call, Number dialled, Exact time of call, Error message shown

Our supplier is investigating this to ensure normal service is maintained.
Posted Nov 20, 2020 - 09:42 UTC
This incident affected: VOIP Phone System.