Customers unable to make outgoing calls
Incident Report for Speak Digital
Resolved
Following a temporary issue calls are now working as normal. Apologies for any inconvenience caused.
Posted Feb 14, 2020 - 14:17 UTC
Investigating
We have had reports that customers outgoing calls are being declined.
The carrier is looking into this and we will come back to you shortly.
Posted Feb 14, 2020 - 14:04 UTC
This incident affected: VOIP Phone System.