Phone outage
Incident Report for Speak Digital
Resolved
Apologies for the interruption in service today.
Posted Jun 07, 2021 - 17:09 UTC
Monitoring
We are starting to see the services coming back to normal.
Apologies for the inconvenience.
Posted Jun 07, 2021 - 12:13 UTC
Identified
Our supplier has identified this as relating to connectivity impacting their central database. This is being worked on as a matter of urgency.
Posted Jun 07, 2021 - 11:17 UTC
Investigating
Our supplier is currently investigating reports of registration of dropping inbound and outbound calls.
Please email helpdesk@speakdigital.co.uk if you are unable to reach us by phone.
Posted Jun 07, 2021 - 11:02 UTC
This incident affected: VOIP Phone System.