Wide Outages on UK Internet - Virgin

Incident Report for Speak Digital

Resolved

Looking at DownDetector the peak of reports for Virgin seems to have dropped back to normal levels. If you are still having problems connecting to any of our services do get in touch.
Posted Feb 24, 2025 - 13:14 UTC

Investigating

We are receiving lots of calls from users who cannot connect to Citrix/RDP. This appears to be caused by a problem with Virgin internet. All services here are operating normally. Please visit https://downdetector.co.uk/ to see more.
Posted Feb 24, 2025 - 10:42 UTC
This incident affected: Other Notifications.