Microsoft 365 Services - Email, Outlook & Teams
Incident Report for Speak Digital
Resolved
Microsoft have resolved this issue. Apologies for any interruption to your services.
Posted Dec 14, 2020 - 10:39 UTC
Identified
Update from Microsoft - they have located the problem that is preventing users from signing in. They are working to bypass the affected servers and believe things will return to normal shortly. Next update due at 11am.
Posted Dec 14, 2020 - 10:03 UTC
Investigating
Users have reported not being able to use Office 365. Microsoft are investigating this at the moment. See https://status.office365.com/ for more information.
Posted Dec 14, 2020 - 09:09 UTC
This incident affected: Microsoft Office 365.