User not found message on Hosted Desktop Login
Incident Report for Speak Digital
Resolved
This incident is now resolved. Thank you for your patience.
Posted Mar 11, 2020 - 11:23 UTC
Identified
The issue that caused this has been identified and we are now testing to see if all is in order.
Posted Mar 11, 2020 - 11:17 UTC
Investigating
Our supplier is currently investigating this issue.
Please bear with us. Sorry for any inconvenience.
Posted Mar 11, 2020 - 11:01 UTC
This incident affected: Citrix Hosted Desktops.