Hosted Servers Offline
Incident Report for Speak Digital
Resolved
This outage was very brief and no tickets were raised so all should be well.
Posted Oct 30, 2024 - 15:39 UTC
Investigating
There appears to be an issue with our hosted servers (not Hosted Desktop / Citrix) which we are currently investigating.
Posted Oct 30, 2024 - 13:37 UTC
This incident affected: Other Notifications.