Outlook freezing / Unable to use Outlook Web Access
Incident Report for Speak Digital
Resolved
We believe this problem is now resolved. Sorry for any inconvenience caused.
Posted Nov 10, 2020 - 17:56 UTC
Monitoring
Although this incident is still live with Microsoft we are not experiencing any problems. We will keep an eye on things before we close this off but if you are still experiencing problems feel free to get in touch.
Posted Nov 10, 2020 - 14:33 UTC
Update
Update from Microsoft: We're continuing to route traffic to alternative mailbox handling infrastructure to mitigate impact. We're seeing an improvement in service health and will continue to monitor until the issue is fully resolved.

The next update should be by 1pm
Posted Nov 10, 2020 - 11:54 UTC
Identified
Microsoft have an ongoing incident EX226193 "Users may be unable to access Exchange Online via multiple connection methods". This has affected some of our users and is causing Outlook to not open or freeze up. They are working to resolve the issue and the next update is expected by 11am.
Posted Nov 10, 2020 - 09:35 UTC
This incident affected: Microsoft Office 365.