Intermittent Service Issues - Connectivity
Incident Report for Speak Digital
Resolved
We observed services return to normal at 13:45. In addition we have had confirmation that a major "Tier 1" internet hub has failed, which is causing many internet services providers to have a knock on affect, our suppliers included.

Whilst our services have stabilised, please anticipate further minor disruptions this afternoon, whilst internet providers rebalance their systems.

If you are experiencing any difficulties, please reach out to our service desk, via the usual channels.
Posted Jun 16, 2022 - 13:27 UTC
Identified
For our hosted desktop services one of the major internet providers is currently experiencing technical issues
Consequently some customers are having difficulty connecting to Citrix/RDP, or cannot load web pages / access their email.

We await an update from the service provider and will post here as soon as we know more.
Apologies for the inconvenience this may cause.
Posted Jun 16, 2022 - 12:48 UTC
This incident affected: Citrix Hosted Desktops.