Microsoft Teams Messages not Sending
Incident Report for Speak Digital
Resolved
This issue is resolved
Posted Mar 20, 2020 - 11:42 UTC
Investigating
Users are reporting that messages are failing on Teams at the moment.
We will update once we know more.
Posted Mar 20, 2020 - 10:10 UTC
This incident affected: Microsoft Office 365.