Major IT Outages Worldwide
Incident Report for Speak Digital
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 10:29 UTC
Monitoring
We want to inform you of a global issue affecting a popular corporate antivirus software, CrowdStrike. This issue is causing significant disruptions for many businesses worldwide. While our services remain unaffected, please be aware that some third-party services you use may experience downtime as a result.

Check https://www.bbc.co.uk/news/articles/cv2g5lvwkl2o for more general information.
Posted Jul 19, 2024 - 07:13 UTC
This incident affected: Other Notifications.