The datacentre is having issues with some of the servers which support our hosted desktop platform

Incident Report for Speak Digital

Resolved

We had to reboot some servers following the initial outage. All services are now working well.
Posted Oct 24, 2024 - 08:07 UTC

Identified

We are still having issues with some of the servers.
We will provide you with an update as soon as possible.
Posted Oct 23, 2024 - 14:46 UTC

Monitoring

We are advised that the issues were caused by a connectivity problem to the data center which has now been resolved. All services appear to be normal. If you are still experiencing problems please do give us a ring.
Posted Oct 23, 2024 - 13:52 UTC

Identified

Engineers are working on this and we will update you as soon as possible
Posted Oct 23, 2024 - 12:59 UTC
This incident affected: Citrix Hosted Desktops.