Linkus Phone System Issues

Incident Report for Speak Digital

Resolved

There was a brief interruption in service which was resolved quickly by the Linkus team. All should now be working as normal.
Posted Jun 01, 2026 - 12:23 UTC

Investigating

We are currently investigating reports of issues affecting customers using Linkus phone systems, including our own internal system. Our team is actively looking into the matter and we will provide an update as soon as possible. We apologise for any inconvenience caused.
Posted Jun 01, 2026 - 11:39 UTC
This incident affected: VOIP Phone System.