Broadband Maintenenace
Incident Report for Speak Digital
Resolved
BT have completed the maintenance in the expected time window.
Posted Feb 25, 2020 - 06:00 UTC
Identified
BT have a planned maintenance window until 6am on 25th February. Broadband may be interrupted for customers but will be restored automatically once the work is complete. Please see https://status.zen.co.uk/broadband/maintenance-outage-details.aspx?reference=303804694 for area codes affected.
Posted Feb 24, 2020 - 23:33 UTC
This incident affected: Broadband / Internet Connectivity.