Inbound and Outbound Calls Failing
Incident Report for Speak Digital
Resolved
A fix has been implemented buy our supplier and calls should now be flowing. Sorry for this brief interruption. If you are still having issues please call 02089707980 or email helpdesk@speakdigital.co.uk
Posted Feb 12, 2021 - 16:44 UTC
Identified
There have been reports of incoming and outgoing calls failing. This issue has already been identified and will be resolved very shortly - please bear with us. If you need support in the meantime please email helpdesk@speakdigital.co.uk
Posted Feb 12, 2021 - 16:37 UTC
This incident affected: VOIP Phone System.