Can't forward or receive external email
Incident Report for Speak Digital
Resolved
Microsoft were able to confirm that re-deploying the spam rule has mitigated impact. They are reviewing their deployment procedures to make sure this type of problem doesn't happen again.
Posted May 26, 2021 - 14:16 UTC
Update
The latest from Microsoft... "We identified that a spam rule was recently replaced with a new one. The new rule has been deployed, however, it has not provided the expected relief. We're re-deploying the new spam rule to remediate impact.". The next update is due by 3pm.
Posted May 26, 2021 - 12:45 UTC
Identified
Microsoft have identified an issue that is preventing automatic forwarding and causing bounce back messages and email delivery issues. It may also be preventing us from receiving tickets so if you log a ticket and do not get an auto response from us then please call in. This is being worked on.
Posted May 26, 2021 - 10:37 UTC
This incident affected: Microsoft Office 365.